martes, 8 de agosto de 2017

,

[Actualización de Software] Git 2.14.0

CMD GIT

Una nueva versión de este potente sistema de control de versiones está disponible.

image

Sitio oficial  de Descarga.

Un método de control de versiones usado por muchas personas es copiar los archivos a otro directorio , El siguiente gran problema con el que se encuentran las personas es que necesitan colaborar con desarrolladores en otros sistemas. Pero con Git este problema deja de existir.

Git nos permite gestionar nuestro proyecto como un repositorio el cual trabaja en forma de una línea temporal, de modo tal que podamos navegar entre las diferentes versiones de nuestro proyecto a lo largo de su existencia.

Este sistema es ideal para quienes suelen necesitar realizar respaldos de su proyecto continuamente, también es muy recomendado para organizaciones dedicadas al desarrollo de software  y que cuentan con múltiples desarrolladores.

distributed

Para los usuarios de Git, esta actualización traes las siguientes características [ENG].

Este post será actualizado constantemente.

Backward compatibility notes and other notable changes.

* Use of an empty string as a pathspec element that is used for 'everything matches' is still warned and Git asks users to use a more explicit '.' for that instead.  The hope is that existing users will not mind this change, and eventually the warning can be turned into a hard error, upgrading the deprecation into removal of this (mis)feature.  That is not scheduled to happen in the upcoming release (yet).

* Git now avoids blindly falling back to ".git" when the setup sequence said we are _not_ in Git repository.  A corner case that happens to work right now may be broken by a call to die("BUG"). We've tried hard to locate such cases and fixed them, but there might still be cases that need to be addressed--bug reports are greatly appreciated.

* The experiment to improve the hunk-boundary selection of textual diff output has finished, and the "indent heuristics" has now become the default.

* Git can now be built with PCRE v2 instead of v1 of the PCRE library. Replace USE_LIBPCRE=YesPlease with USE_LIBPCRE2=YesPlease in existing build scripts to build against the new version.  As the upstream PCRE maintainer has abandoned v1 maintenance for all but the most critical bug fixes, use of v2 is recommended.

Compartir:

0 comentarios:

Publicar un comentario